Embedded Registration with Hubspot and Marketo is not loading right, working on to fix ASAP

Incident Report for Goldcast

Resolved

Fix is deployed, please refresh the page
Posted Apr 28, 2025 - 16:48 UTC

Update

We are continuing to investigate this issue.
Posted Apr 28, 2025 - 16:43 UTC

Investigating

We are currently investigating this issue.
Posted Apr 28, 2025 - 16:43 UTC
This incident affected: Registration Pages.